If you’re ever tried to install the Zabbix agent on a Linux server and gotten an error like this, you’re in the right place to find help:

$ apt install zabbix-agent
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
zabbix-agent : Depends: libssl1.1 (>= 1.1.1) but 1.1.0g-2ubuntu4 is to be installed
E: Unable to correct problems, you have held broken packages.

Cause #1: Mismatched Repository

A common issue is that error 99% means it’s trying the wrong OS version since libssl is built in to the OS.  Check to make sure the package or package repository you are trying to install from matches your OS’ version.  Zabbix hosts a nice repository finder tool on it’s download page for this.

Cause #2: Missing “-security” Repository

Rarer is a missing repository such as “bionic-security” (or similar for your OS version) which has updated SSL libraries for your version of Ubuntu. “Bionic” in this case is an example for Ubuntu 18.x.

To enable the appropriate -security repo edit /etc/apt/sources.list ala:

sudo nano /etc/apt/sources.list

And uncomment the lines/sources for the -security repository.

Call 1-828-376-0458 to Work With Linux Server Experts

Professional Linux support from senior Linux systems engineers.


Leave a Reply

Your email address will not be published. Required fields are marked *

This site uses Akismet to reduce spam. Learn how your comment data is processed.